Problem:
Printers on Mac devices are suddenly not being redirected through JumpDesktop when using the ThinPrint Client Mac for RDP.
Cause:
This issue is typically due to a conflict between the JumpDesktop virtual channel interface and the ThinPrint Client, causing the ThinPrint Client to not be automatically loaded during session initialization.
Solution:
To resolve the issue, install ThinPrint Client 12 for Mac RDP from our Download Page.
The new ThinPrint Client 12 for Mac RDP requires the installation of Jump Desktop web version 8.8.28 or later directly from the website, not from the Apple App Store.