Problem
Local printers do not map within a Citrix session.
Cause
The ThinPrint ICA Client may not start with a XenApp session, typically during the installation or update of relevant components.
An error will appear in the ThinPrint Diagnostics Log:
- Event ID 4002: Can't connect to virtual channel (50)
Applies to product
ThinPrint Engine 10+
ThinPrint Client ICA 10+
Solution
If using the ICA print protocol, ensure the correct installation order of components. Both Citrix Receiver and ThinPrint Client must be installed with administrator rights.
Installation steps:
Install Citrix Receiver.
- For updates or reinstallation, uninstall the existing version and manually delete the folder at
C:\Program Files (x86)\Citrix
before proceeding.
- For updates or reinstallation, uninstall the existing version and manually delete the folder at
Start a XenApp session.
Install ThinPrint ICA Client.
- After installation, log off from the workstation.
Start a new XenApp session.
- The ThinPrint ICA Client should now start automatically (verify by checking the TP Client icon in the system tray).