Problem
Lokale Drucker werden in der Citrix-Sitzung nicht gemappt.
Ursache
Der ThinPrint ICA-Client startet möglicherweise nicht mit einer XenApp-Sitzung. Dies kann während der Neuinstallation oder Aktualisierung relevanter Komponenten auftreten.
Im ThinPrint-Diagnoselprotokoll erscheint eine Fehlermeldung:
- Ereignis-ID 4002: Verbindung zum virtuellen Kanal (50) fehlgeschlagen.
Gilt für
- ThinPrint Engine 10+
- ThinPrint Client ICA 10+
Lösung
Falls das ICA-Druckprotokoll verwendet wird, ist die richtige Installationsreihenfolge der Komponenten zu beachten. Sowohl der Citrix Receiver als auch der ThinPrint Client müssen mit Administratorrechten installiert werden.
Installationsschritte:
Citrix Receiver installieren.
- Bei einer Aktualisierung oder Neuinstallation bitte die alte Version deinstallieren und den Ordner
C:\Program Files (x86)\Citrix
manuell löschen, bevor die Neuinstallation erfolgt.
- Bei einer Aktualisierung oder Neuinstallation bitte die alte Version deinstallieren und den Ordner
XenApp-Sitzung starten.
ThinPrint ICA-Client installieren.
- Nach der Installation einmal vom Arbeitsplatz abmelden.
Neue XenApp-Sitzung starten.
- Der ThinPrint ICA-Client sollte nun automatisch starten (das TP-Client-Symbol im Systemtray prüfen).
Durch die Einhaltung dieser Schritte sollten Probleme mit dem Druckermapping behoben werden.